Xima Software - UC API delays – Incident details

All systems operational

UC API delays

Resolved
Degraded performance
Started 2 months agoLasted about 7 hours

Affected

Xima UCaaS

Degraded performance from 5:10 PM to 11:47 PM

Inbound/Outbound Calling

Degraded performance from 5:10 PM to 11:47 PM

Xima CCaaS - Voice

Degraded performance from 5:10 PM to 11:47 PM

IVR Routing

Degraded performance from 5:10 PM to 11:47 PM

Inbound/Outbound Calling

Degraded performance from 5:10 PM to 11:47 PM

Contact Center Agent Client

Degraded performance from 5:10 PM to 11:47 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    We are rolling out a fix and are monitoring to ensure the issue is resolved.

  • Identified
    UTC
    Identified

    We're seeing intermittant latency issues with our ISP on traffic egressing from the NJ data center to FL and sporadically to LV. We are working on moving affected sites to a different API endpoint to adjust for this latency.

  • Investigating
    UTC
    Investigating

    We are currently investigating an issues with our UCaaS system where API delays are causing routing and agent state issues for certain CCaaS customers that also utilize Xima UC. Issue can range from Phone Not Available states in Supervisor view, ACW issues, and call routing issues. This is high priority and we will update shortly with more information as we work on resolving this delay.